Oops! Error: npm doesn’t work with node v0.6.0

Hello again, today is wonderful day right? Except for me. A couple weeks ago I upgraded the nodejs to v0.6.0.  Tonight, I want to install a few nodejs modules using the Node Package Manager but I got an error told me that the npm doesn’t work with node v0.6.0.:

Error: npm doesn't work with node v0.6.0
Required: node@0.4 || 0.5
 at /usr/local/lib/node_modules/npm/bin/npm-cli.js:57:23
 at Object. (/usr/local/lib/node_modules/npm/bin/npm-cli.js:77:2)
 at Module._compile (module.js:432:26)
 at Object..js (module.js:450:10)
 at Module.load (module.js:351:31)
 at Function._load (module.js:310:12)
 at Array.0 (module.js:470:10)
 at EventEmitter._tickCallback (node.js:192:40)

What a wonderful night and I want to find out the workaround for this problem. Do I have revert to node v0.4.0. or just stick with the v0.6.0?

I’ll be back!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s