Can’t install the Blaast SDK on Ubuntu 11.04 because of node-stringprep@0.0.5 Failed to exec install script

node-stringprep failed to exec script

node-stringprep failed to exec script

Hello, yesterday I failed to install the newest Blaast SDK (version 20111027). In the first time, I just don’t know what’s wrong with the node-stringprep package, so everytime I try to run the installation is always failed.

So, I visit the official node-stringprep project on https://github.com/astro/node-stringprep and found this section:

Installation
apt-get install libicu-dev # Debian
emerge icu # Gentoo
port install icu +devel # OSX using macports
npm install node-stringprep

My assumption the Blaast SDK installation is failed because there is dependencies package I have not install yet, then I run this command:

apt-get install libicu-dev

After, the libicu-dev sucesfully installed I run the Blaast SDK installation again and the installation is run smoothly.

So, guys if you experienced the same problem like me here, it could be the libicu-dev package is not already installed on your Ubuntu 11.04 box.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s